uboot-sunxi: bump to 2020.01
Refreshed patches, removed following, probably obsolete patches: 221-compatible-old-dtc.patch 240-sun50i-h5-Orange-Pi-Zero-Plus-Fix-SdCard-detection.patch Signed-off-by: Petr Štetiar <ynezz@true.cz>
This commit is contained in:
parent
5fbcb52648
commit
48436953e9
@ -9,9 +9,9 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_VERSION:=2019.01
|
PKG_VERSION:=2020.01
|
||||||
|
|
||||||
PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
|
PKG_HASH:=aa453c603208b1b27bd03525775a7f79b443adec577fdc6e8f06974025a135f1
|
||||||
|
|
||||||
PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
|
PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/arm/dts/Makefile
|
--- a/arch/arm/dts/Makefile
|
||||||
+++ b/arch/arm/dts/Makefile
|
+++ b/arch/arm/dts/Makefile
|
||||||
@@ -313,6 +313,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
|
@@ -446,6 +446,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
|
||||||
sun6i-a31-m9.dtb \
|
sun6i-a31-m9.dtb \
|
||||||
sun6i-a31-mele-a1000g-quad.dtb \
|
sun6i-a31-mele-a1000g-quad.dtb \
|
||||||
sun6i-a31-mixtile-loftq.dtb \
|
sun6i-a31-mixtile-loftq.dtb \
|
||||||
@ -358,7 +358,7 @@
|
|||||||
+CONFIG_SUNXI_SPI=y
|
+CONFIG_SUNXI_SPI=y
|
||||||
--- a/arch/arm/mach-sunxi/Kconfig
|
--- a/arch/arm/mach-sunxi/Kconfig
|
||||||
+++ b/arch/arm/mach-sunxi/Kconfig
|
+++ b/arch/arm/mach-sunxi/Kconfig
|
||||||
@@ -875,6 +875,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
|
@@ -895,6 +895,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
|
||||||
Set the SCL pin for the LCD i2c interface. This takes a string in the
|
Set the SCL pin for the LCD i2c interface. This takes a string in the
|
||||||
format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.
|
format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.
|
||||||
|
|
||||||
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
--- a/configs/A20-OLinuXino-Lime2_defconfig
|
--- a/configs/A20-OLinuXino-Lime2_defconfig
|
||||||
+++ b/configs/A20-OLinuXino-Lime2_defconfig
|
+++ b/configs/A20-OLinuXino-Lime2_defconfig
|
||||||
@@ -25,6 +25,7 @@ CONFIG_ETH_DESIGNWARE=y
|
@@ -26,6 +26,7 @@ CONFIG_ETH_DESIGNWARE=y
|
||||||
CONFIG_RGMII=y
|
CONFIG_RGMII=y
|
||||||
CONFIG_MII=y
|
CONFIG_MII=y
|
||||||
CONFIG_SUN7I_GMAC=y
|
CONFIG_SUN7I_GMAC=y
|
||||||
|
@ -1,17 +1,17 @@
|
|||||||
--- a/configs/A20-OLinuXino-Lime2-eMMC_defconfig
|
--- a/configs/A20-OLinuXino-Lime2-eMMC_defconfig
|
||||||
+++ b/configs/A20-OLinuXino-Lime2-eMMC_defconfig
|
+++ b/configs/A20-OLinuXino-Lime2-eMMC_defconfig
|
||||||
@@ -8,6 +8,8 @@ CONFIG_MMC_SUNXI_SLOT_EXTRA=2
|
@@ -9,6 +9,8 @@ CONFIG_MMC_SUNXI_SLOT_EXTRA=2
|
||||||
CONFIG_USB0_VBUS_PIN="PC17"
|
CONFIG_USB0_VBUS_PIN="PC17"
|
||||||
CONFIG_USB0_VBUS_DET="PH5"
|
CONFIG_USB0_VBUS_DET="PH5"
|
||||||
CONFIG_I2C1_ENABLE=y
|
CONFIG_I2C1_ENABLE=y
|
||||||
+CONFIG_PHY_MICREL=y
|
+CONFIG_PHY_MICREL=y
|
||||||
+CONFIG_PHY_MICREL_KSZ90X1=y
|
+CONFIG_PHY_MICREL_KSZ90X1=y
|
||||||
CONFIG_SATAPWR="PC3"
|
CONFIG_SATAPWR="PC3"
|
||||||
|
CONFIG_SPL_SPI_SUNXI=y
|
||||||
CONFIG_AHCI=y
|
CONFIG_AHCI=y
|
||||||
CONFIG_NR_DRAM_BANKS=1
|
|
||||||
--- a/configs/A20-OLinuXino-Lime2_defconfig
|
--- a/configs/A20-OLinuXino-Lime2_defconfig
|
||||||
+++ b/configs/A20-OLinuXino-Lime2_defconfig
|
+++ b/configs/A20-OLinuXino-Lime2_defconfig
|
||||||
@@ -7,6 +7,8 @@ CONFIG_MMC0_CD_PIN="PH1"
|
@@ -8,6 +8,8 @@ CONFIG_MMC0_CD_PIN="PH1"
|
||||||
CONFIG_USB0_VBUS_PIN="PC17"
|
CONFIG_USB0_VBUS_PIN="PC17"
|
||||||
CONFIG_USB0_VBUS_DET="PH5"
|
CONFIG_USB0_VBUS_DET="PH5"
|
||||||
CONFIG_I2C1_ENABLE=y
|
CONFIG_I2C1_ENABLE=y
|
||||||
@ -19,10 +19,10 @@
|
|||||||
+CONFIG_PHY_MICREL_KSZ90X1=y
|
+CONFIG_PHY_MICREL_KSZ90X1=y
|
||||||
CONFIG_SATAPWR="PC3"
|
CONFIG_SATAPWR="PC3"
|
||||||
CONFIG_AHCI=y
|
CONFIG_AHCI=y
|
||||||
CONFIG_NR_DRAM_BANKS=1
|
# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
|
||||||
--- a/drivers/net/phy/micrel_ksz90x1.c
|
--- a/drivers/net/phy/micrel_ksz90x1.c
|
||||||
+++ b/drivers/net/phy/micrel_ksz90x1.c
|
+++ b/drivers/net/phy/micrel_ksz90x1.c
|
||||||
@@ -13,6 +13,8 @@
|
@@ -14,6 +14,8 @@
|
||||||
#include <errno.h>
|
#include <errno.h>
|
||||||
#include <micrel.h>
|
#include <micrel.h>
|
||||||
#include <phy.h>
|
#include <phy.h>
|
||||||
@ -31,7 +31,7 @@
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* KSZ9021 - KSZ9031 common
|
* KSZ9021 - KSZ9031 common
|
||||||
@@ -329,6 +331,10 @@ static int ksz9031_phy_extwrite(struct p
|
@@ -344,6 +346,10 @@ static int ksz9031_phy_extwrite(struct p
|
||||||
static int ksz9031_config(struct phy_device *phydev)
|
static int ksz9031_config(struct phy_device *phydev)
|
||||||
{
|
{
|
||||||
int ret;
|
int ret;
|
||||||
|
@ -28,5 +28,5 @@ More specifically, the following settings are now used:
|
|||||||
+ k = 4;
|
+ k = 4;
|
||||||
+ m = 2;
|
+ m = 2;
|
||||||
} else if (clk > 768000000) {
|
} else if (clk > 768000000) {
|
||||||
k = 3;
|
k = 4;
|
||||||
m = 2;
|
m = 2;
|
||||||
|
@ -6,7 +6,7 @@ Subject: sun6i: define alternate-function for UART2 on GPG
|
|||||||
|
|
||||||
--- a/arch/arm/include/asm/arch-sunxi/gpio.h
|
--- a/arch/arm/include/asm/arch-sunxi/gpio.h
|
||||||
+++ b/arch/arm/include/asm/arch-sunxi/gpio.h
|
+++ b/arch/arm/include/asm/arch-sunxi/gpio.h
|
||||||
@@ -186,6 +186,7 @@ enum sunxi_gpio_number {
|
@@ -190,6 +190,7 @@ enum sunxi_gpio_number {
|
||||||
#define SUN6I_GPG_SDC1 2
|
#define SUN6I_GPG_SDC1 2
|
||||||
#define SUN8I_GPG_SDC1 2
|
#define SUN8I_GPG_SDC1 2
|
||||||
#define SUN6I_GPG_TWI3 2
|
#define SUN6I_GPG_TWI3 2
|
||||||
|
@ -6,7 +6,7 @@ Subject: ARM: sun6i: Support console on UART2 (GPG6/GPG7)
|
|||||||
|
|
||||||
--- a/arch/arm/mach-sunxi/board.c
|
--- a/arch/arm/mach-sunxi/board.c
|
||||||
+++ b/arch/arm/mach-sunxi/board.c
|
+++ b/arch/arm/mach-sunxi/board.c
|
||||||
@@ -127,6 +127,10 @@ static int gpio_init(void)
|
@@ -129,6 +129,10 @@ static int gpio_init(void)
|
||||||
sunxi_gpio_set_cfgpin(SUNXI_GPG(3), SUN5I_GPG_UART1);
|
sunxi_gpio_set_cfgpin(SUNXI_GPG(3), SUN5I_GPG_UART1);
|
||||||
sunxi_gpio_set_cfgpin(SUNXI_GPG(4), SUN5I_GPG_UART1);
|
sunxi_gpio_set_cfgpin(SUNXI_GPG(4), SUN5I_GPG_UART1);
|
||||||
sunxi_gpio_set_pull(SUNXI_GPG(4), SUNXI_GPIO_PULL_UP);
|
sunxi_gpio_set_pull(SUNXI_GPG(4), SUNXI_GPIO_PULL_UP);
|
||||||
@ -19,7 +19,7 @@ Subject: ARM: sun6i: Support console on UART2 (GPG6/GPG7)
|
|||||||
sunxi_gpio_set_cfgpin(SUNXI_GPB(1), SUN8I_GPB_UART2);
|
sunxi_gpio_set_cfgpin(SUNXI_GPB(1), SUN8I_GPB_UART2);
|
||||||
--- a/include/configs/sunxi-common.h
|
--- a/include/configs/sunxi-common.h
|
||||||
+++ b/include/configs/sunxi-common.h
|
+++ b/include/configs/sunxi-common.h
|
||||||
@@ -258,6 +258,8 @@ extern int soft_i2c_gpio_scl;
|
@@ -244,6 +244,8 @@ extern int soft_i2c_gpio_scl;
|
||||||
#endif
|
#endif
|
||||||
#elif CONFIG_CONS_INDEX == 2 && defined(CONFIG_MACH_SUN5I)
|
#elif CONFIG_CONS_INDEX == 2 && defined(CONFIG_MACH_SUN5I)
|
||||||
#define OF_STDOUT_PATH "/soc@01c00000/serial@01c28400:115200"
|
#define OF_STDOUT_PATH "/soc@01c00000/serial@01c28400:115200"
|
||||||
|
@ -6,7 +6,7 @@ Subject: ARM: sunxi: Make CONS_INDEX configurable
|
|||||||
|
|
||||||
--- a/arch/arm/mach-sunxi/Kconfig
|
--- a/arch/arm/mach-sunxi/Kconfig
|
||||||
+++ b/arch/arm/mach-sunxi/Kconfig
|
+++ b/arch/arm/mach-sunxi/Kconfig
|
||||||
@@ -538,6 +538,14 @@ config SYS_BOARD
|
@@ -558,6 +558,14 @@ config SYS_BOARD
|
||||||
config SYS_SOC
|
config SYS_SOC
|
||||||
default "sunxi"
|
default "sunxi"
|
||||||
|
|
||||||
|
@ -17,7 +17,7 @@ Cc: Simon Glass <sjg@chromium.org>
|
|||||||
|
|
||||||
--- a/tools/fit_image.c
|
--- a/tools/fit_image.c
|
||||||
+++ b/tools/fit_image.c
|
+++ b/tools/fit_image.c
|
||||||
@@ -656,9 +656,14 @@ static int fit_handle_file(struct image_
|
@@ -662,9 +662,14 @@ static int fit_handle_file(struct image_
|
||||||
}
|
}
|
||||||
*cmd = '\0';
|
*cmd = '\0';
|
||||||
} else if (params->datafile) {
|
} else if (params->datafile) {
|
||||||
|
@ -12,7 +12,7 @@ old way of generating images.
|
|||||||
|
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1344,8 +1344,10 @@ endif
|
@@ -1525,8 +1525,10 @@ endif
|
||||||
|
|
||||||
ifneq ($(CONFIG_ARCH_SUNXI),)
|
ifneq ($(CONFIG_ARCH_SUNXI),)
|
||||||
ifeq ($(CONFIG_ARM64),)
|
ifeq ($(CONFIG_ARM64),)
|
||||||
@ -27,7 +27,7 @@ old way of generating images.
|
|||||||
$(call if_changed,cat)
|
$(call if_changed,cat)
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -842,7 +842,6 @@ config ARCH_SOCFPGA
|
@@ -945,7 +945,6 @@ config ARCH_SOCFPGA
|
||||||
|
|
||||||
config ARCH_SUNXI
|
config ARCH_SUNXI
|
||||||
bool "Support sunxi (Allwinner) SoCs"
|
bool "Support sunxi (Allwinner) SoCs"
|
||||||
|
@ -1,52 +0,0 @@
|
|||||||
Revert the commit c0e032e0090d65 ("scripts/dtc: Update to upstream
|
|
||||||
version v1.4.3")
|
|
||||||
OpenWrt uses the dtc from the kernel also in u-boot, but when we compile
|
|
||||||
against kernel 4.9 we run into some errors because it is too old now.
|
|
||||||
Add the options only when they are supported to make it compatible with
|
|
||||||
dtc from kernel 4.9.
|
|
||||||
|
|
||||||
--- a/scripts/Kbuild.include
|
|
||||||
+++ b/scripts/Kbuild.include
|
|
||||||
@@ -173,6 +173,11 @@ ld-version = $(shell $(LD) --version | $
|
|
||||||
# Usage: $(call ld-ifversion, -ge, 22252, y)
|
|
||||||
ld-ifversion = $(shell [ $(ld-version) $(1) $(2) ] && echo $(3) || echo $(4))
|
|
||||||
|
|
||||||
+# dtc-option
|
|
||||||
+# Usage: DTC_FLAGS += $(call dtc-option,-Wno-unit_address_vs_reg)
|
|
||||||
+dtc-option = $(call try-run,\
|
|
||||||
+ echo '/dts-v1/; / {};' | $(DTC) $(1),$(1),$(2))
|
|
||||||
+
|
|
||||||
######
|
|
||||||
|
|
||||||
###
|
|
||||||
--- a/scripts/Makefile.extrawarn
|
|
||||||
+++ b/scripts/Makefile.extrawarn
|
|
||||||
@@ -56,8 +56,8 @@ endif
|
|
||||||
|
|
||||||
KBUILD_CFLAGS += $(warning)
|
|
||||||
|
|
||||||
-dtc-warning-2 += -Wnode_name_chars_strict
|
|
||||||
-dtc-warning-2 += -Wproperty_name_chars_strict
|
|
||||||
+dtc-warning-2 += $(call dtc-option,-Wnode_name_chars_strict)
|
|
||||||
+dtc-warning-2 += $(call dtc-option,-Wproperty_name_chars_strict)
|
|
||||||
|
|
||||||
dtc-warning := $(dtc-warning-$(findstring 1, $(KBUILD_ENABLE_EXTRA_GCC_CHECKS)))
|
|
||||||
dtc-warning += $(dtc-warning-$(findstring 2, $(KBUILD_ENABLE_EXTRA_GCC_CHECKS)))
|
|
||||||
@@ -68,11 +68,11 @@ DTC_FLAGS += $(dtc-warning)
|
|
||||||
else
|
|
||||||
|
|
||||||
# Disable noisy checks by default
|
|
||||||
-DTC_FLAGS += -Wno-unit_address_vs_reg
|
|
||||||
-DTC_FLAGS += -Wno-simple_bus_reg
|
|
||||||
-DTC_FLAGS += -Wno-unit_address_format
|
|
||||||
-DTC_FLAGS += -Wno-pci_bridge
|
|
||||||
-DTC_FLAGS += -Wno-pci_device_bus_num
|
|
||||||
-DTC_FLAGS += -Wno-pci_device_reg
|
|
||||||
+DTC_FLAGS += $(call dtc-option,-Wno-unit_address_vs_reg)
|
|
||||||
+DTC_FLAGS += $(call dtc-option,-Wno-simple_bus_reg)
|
|
||||||
+DTC_FLAGS += $(call dtc-option,-Wno-unit_address_format)
|
|
||||||
+DTC_FLAGS += $(call dtc-option,-Wno-pci_bridge)
|
|
||||||
+DTC_FLAGS += $(call dtc-option,-Wno-pci_device_bus_num)
|
|
||||||
+DTC_FLAGS += $(call dtc-option,-Wno-pci_device_reg)
|
|
||||||
|
|
||||||
endif
|
|
@ -1,6 +1,6 @@
|
|||||||
--- a/configs/A13-OLinuXino_defconfig
|
--- a/configs/A13-OLinuXino_defconfig
|
||||||
+++ b/configs/A13-OLinuXino_defconfig
|
+++ b/configs/A13-OLinuXino_defconfig
|
||||||
@@ -7,7 +7,6 @@ CONFIG_DRAM_EMR1=0
|
@@ -8,7 +8,6 @@ CONFIG_DRAM_EMR1=0
|
||||||
CONFIG_MMC0_CD_PIN="PG0"
|
CONFIG_MMC0_CD_PIN="PG0"
|
||||||
CONFIG_USB0_VBUS_DET="PG1"
|
CONFIG_USB0_VBUS_DET="PG1"
|
||||||
CONFIG_USB1_VBUS_PIN="PG11"
|
CONFIG_USB1_VBUS_PIN="PG11"
|
||||||
@ -8,12 +8,12 @@
|
|||||||
# CONFIG_VIDEO_HDMI is not set
|
# CONFIG_VIDEO_HDMI is not set
|
||||||
CONFIG_VIDEO_VGA_VIA_LCD=y
|
CONFIG_VIDEO_VGA_VIA_LCD=y
|
||||||
CONFIG_VIDEO_VGA_VIA_LCD_FORCE_SYNC_ACTIVE_HIGH=y
|
CONFIG_VIDEO_VGA_VIA_LCD_FORCE_SYNC_ACTIVE_HIGH=y
|
||||||
@@ -24,7 +23,7 @@ CONFIG_CMD_USB_MASS_STORAGE=y
|
@@ -25,7 +24,7 @@ CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-ol
|
||||||
CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-olinuxino"
|
CONFIG_SYS_RELOC_GD_ENV_ADDR=y
|
||||||
CONFIG_DFU_RAM=y
|
CONFIG_DFU_RAM=y
|
||||||
CONFIG_FASTBOOT_CMD_OEM_FORMAT=y
|
CONFIG_FASTBOOT_CMD_OEM_FORMAT=y
|
||||||
-CONFIG_AXP_ALDO3_VOLT=3300
|
-CONFIG_AXP_ALDO3_VOLT=3300
|
||||||
+CONFIG_SUNXI_NO_PMIC=y
|
+CONFIG_SUNXI_NO_PMIC=y
|
||||||
CONFIG_CONS_INDEX=2
|
CONFIG_CONS_INDEX=2
|
||||||
CONFIG_USB_EHCI_HCD=y
|
CONFIG_USB_EHCI_HCD=y
|
||||||
CONFIG_USB_MUSB_GADGET=y
|
CONFIG_USB_OHCI_HCD=y
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
From ad320d4d6ad03af5ff730546113d53a47ef6a22e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
||||||
Date: Sun, 13 Jan 2019 17:05:09 +0100
|
|
||||||
Subject: [PATCH] sun50i: h5: Orange Pi Zero Plus: Fix SdCard detection
|
|
||||||
|
|
||||||
The Detection pin is at PF6 and not at PH13 like defined before. I
|
|
||||||
checked the schematics and now I am am not seeing this error message any
|
|
||||||
more:
|
|
||||||
Loading Environment from FAT... Card did not respond to voltage select!
|
|
||||||
|
|
||||||
Fixes: 76d69eb01de ("sun50i: h5: Add initial Orange Pi Zero Plus support")
|
|
||||||
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|
||||||
---
|
|
||||||
configs/orangepi_zero_plus_defconfig | 3 +--
|
|
||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
||||||
|
|
||||||
--- a/configs/orangepi_zero_plus_defconfig
|
|
||||||
+++ b/configs/orangepi_zero_plus_defconfig
|
|
||||||
@@ -4,8 +4,7 @@ CONFIG_SPL=y
|
|
||||||
CONFIG_MACH_SUN50I_H5=y
|
|
||||||
CONFIG_DRAM_CLK=624
|
|
||||||
CONFIG_DRAM_ZQ=3881977
|
|
||||||
-CONFIG_MMC0_CD_PIN="PH13"
|
|
||||||
-CONFIG_MMC_SUNXI_SLOT_EXTRA=2
|
|
||||||
+CONFIG_MMC0_CD_PIN="PF6"
|
|
||||||
CONFIG_NR_DRAM_BANKS=1
|
|
||||||
# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
|
|
||||||
# CONFIG_CMD_FLASH is not set
|
|
Loading…
x
Reference in New Issue
Block a user