uboot-sunxi: bump to 2020.04 relase
Refreshed patches, removed upstreamed patch: 260-configs-a64-olinuxino-emmc-add-eMMC-boot-part-config.patch Boot tested on a64-olinuxino-emmc. Cc: Zoltan HERPAI <wigyori@uid0.hu> Signed-off-by: Petr Štetiar <ynezz@true.cz>
This commit is contained in:
parent
260a225ba4
commit
8e99bbda19
@ -9,9 +9,9 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_VERSION:=2020.01
|
PKG_VERSION:=2020.04
|
||||||
|
|
||||||
PKG_HASH:=aa453c603208b1b27bd03525775a7f79b443adec577fdc6e8f06974025a135f1
|
PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
|
||||||
|
|
||||||
PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
|
PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/arm/dts/Makefile
|
--- a/arch/arm/dts/Makefile
|
||||||
+++ b/arch/arm/dts/Makefile
|
+++ b/arch/arm/dts/Makefile
|
||||||
@@ -446,6 +446,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
|
@@ -455,6 +455,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
|
||||||
sun6i-a31-m9.dtb \
|
sun6i-a31-m9.dtb \
|
||||||
sun6i-a31-mele-a1000g-quad.dtb \
|
sun6i-a31-mele-a1000g-quad.dtb \
|
||||||
sun6i-a31-mixtile-loftq.dtb \
|
sun6i-a31-mixtile-loftq.dtb \
|
||||||
@ -358,7 +358,7 @@
|
|||||||
+CONFIG_SUNXI_SPI=y
|
+CONFIG_SUNXI_SPI=y
|
||||||
--- a/arch/arm/mach-sunxi/Kconfig
|
--- a/arch/arm/mach-sunxi/Kconfig
|
||||||
+++ b/arch/arm/mach-sunxi/Kconfig
|
+++ b/arch/arm/mach-sunxi/Kconfig
|
||||||
@@ -895,6 +895,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
|
@@ -896,6 +896,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
|
||||||
Set the SCL pin for the LCD i2c interface. This takes a string in the
|
Set the SCL pin for the LCD i2c interface. This takes a string in the
|
||||||
format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.
|
format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.
|
||||||
|
|
||||||
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
--- a/configs/A20-OLinuXino-Lime2_defconfig
|
--- a/configs/A20-OLinuXino-Lime2_defconfig
|
||||||
+++ b/configs/A20-OLinuXino-Lime2_defconfig
|
+++ b/configs/A20-OLinuXino-Lime2_defconfig
|
||||||
@@ -26,6 +26,7 @@ CONFIG_ETH_DESIGNWARE=y
|
@@ -22,6 +22,7 @@ CONFIG_ETH_DESIGNWARE=y
|
||||||
CONFIG_RGMII=y
|
CONFIG_RGMII=y
|
||||||
CONFIG_MII=y
|
CONFIG_MII=y
|
||||||
CONFIG_SUN7I_GMAC=y
|
CONFIG_SUN7I_GMAC=y
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/configs/A20-OLinuXino-Lime2-eMMC_defconfig
|
--- a/configs/A20-OLinuXino-Lime2-eMMC_defconfig
|
||||||
+++ b/configs/A20-OLinuXino-Lime2-eMMC_defconfig
|
+++ b/configs/A20-OLinuXino-Lime2-eMMC_defconfig
|
||||||
@@ -9,6 +9,8 @@ CONFIG_MMC_SUNXI_SLOT_EXTRA=2
|
@@ -8,6 +8,8 @@ CONFIG_MMC_SUNXI_SLOT_EXTRA=2
|
||||||
CONFIG_USB0_VBUS_PIN="PC17"
|
CONFIG_USB0_VBUS_PIN="PC17"
|
||||||
CONFIG_USB0_VBUS_DET="PH5"
|
CONFIG_USB0_VBUS_DET="PH5"
|
||||||
CONFIG_I2C1_ENABLE=y
|
CONFIG_I2C1_ENABLE=y
|
||||||
@ -11,7 +11,7 @@
|
|||||||
CONFIG_AHCI=y
|
CONFIG_AHCI=y
|
||||||
--- a/configs/A20-OLinuXino-Lime2_defconfig
|
--- a/configs/A20-OLinuXino-Lime2_defconfig
|
||||||
+++ b/configs/A20-OLinuXino-Lime2_defconfig
|
+++ b/configs/A20-OLinuXino-Lime2_defconfig
|
||||||
@@ -8,6 +8,8 @@ CONFIG_MMC0_CD_PIN="PH1"
|
@@ -7,6 +7,8 @@ CONFIG_MMC0_CD_PIN="PH1"
|
||||||
CONFIG_USB0_VBUS_PIN="PC17"
|
CONFIG_USB0_VBUS_PIN="PC17"
|
||||||
CONFIG_USB0_VBUS_DET="PH5"
|
CONFIG_USB0_VBUS_DET="PH5"
|
||||||
CONFIG_I2C1_ENABLE=y
|
CONFIG_I2C1_ENABLE=y
|
||||||
|
@ -6,7 +6,7 @@ Subject: ARM: sunxi: Make CONS_INDEX configurable
|
|||||||
|
|
||||||
--- a/arch/arm/mach-sunxi/Kconfig
|
--- a/arch/arm/mach-sunxi/Kconfig
|
||||||
+++ b/arch/arm/mach-sunxi/Kconfig
|
+++ b/arch/arm/mach-sunxi/Kconfig
|
||||||
@@ -558,6 +558,14 @@ config SYS_BOARD
|
@@ -559,6 +559,14 @@ config SYS_BOARD
|
||||||
config SYS_SOC
|
config SYS_SOC
|
||||||
default "sunxi"
|
default "sunxi"
|
||||||
|
|
||||||
|
@ -17,7 +17,7 @@ Cc: Simon Glass <sjg@chromium.org>
|
|||||||
|
|
||||||
--- a/tools/fit_image.c
|
--- a/tools/fit_image.c
|
||||||
+++ b/tools/fit_image.c
|
+++ b/tools/fit_image.c
|
||||||
@@ -662,9 +662,14 @@ static int fit_handle_file(struct image_
|
@@ -726,9 +726,14 @@ static int fit_handle_file(struct image_
|
||||||
}
|
}
|
||||||
*cmd = '\0';
|
*cmd = '\0';
|
||||||
} else if (params->datafile) {
|
} else if (params->datafile) {
|
||||||
|
@ -12,7 +12,7 @@ old way of generating images.
|
|||||||
|
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1525,8 +1525,10 @@ endif
|
@@ -1555,8 +1555,10 @@ endif
|
||||||
|
|
||||||
ifneq ($(CONFIG_ARCH_SUNXI),)
|
ifneq ($(CONFIG_ARCH_SUNXI),)
|
||||||
ifeq ($(CONFIG_ARM64),)
|
ifeq ($(CONFIG_ARM64),)
|
||||||
@ -27,7 +27,7 @@ old way of generating images.
|
|||||||
$(call if_changed,cat)
|
$(call if_changed,cat)
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -945,7 +945,6 @@ config ARCH_SOCFPGA
|
@@ -962,7 +962,6 @@ config ARCH_SOCFPGA
|
||||||
|
|
||||||
config ARCH_SUNXI
|
config ARCH_SUNXI
|
||||||
bool "Support sunxi (Allwinner) SoCs"
|
bool "Support sunxi (Allwinner) SoCs"
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/configs/A13-OLinuXino_defconfig
|
--- a/configs/A13-OLinuXino_defconfig
|
||||||
+++ b/configs/A13-OLinuXino_defconfig
|
+++ b/configs/A13-OLinuXino_defconfig
|
||||||
@@ -8,7 +8,6 @@ CONFIG_DRAM_EMR1=0
|
@@ -7,7 +7,6 @@ CONFIG_DRAM_EMR1=0
|
||||||
CONFIG_MMC0_CD_PIN="PG0"
|
CONFIG_MMC0_CD_PIN="PG0"
|
||||||
CONFIG_USB0_VBUS_DET="PG1"
|
CONFIG_USB0_VBUS_DET="PG1"
|
||||||
CONFIG_USB1_VBUS_PIN="PG11"
|
CONFIG_USB1_VBUS_PIN="PG11"
|
||||||
@ -8,8 +8,8 @@
|
|||||||
# CONFIG_VIDEO_HDMI is not set
|
# CONFIG_VIDEO_HDMI is not set
|
||||||
CONFIG_VIDEO_VGA_VIA_LCD=y
|
CONFIG_VIDEO_VGA_VIA_LCD=y
|
||||||
CONFIG_VIDEO_VGA_VIA_LCD_FORCE_SYNC_ACTIVE_HIGH=y
|
CONFIG_VIDEO_VGA_VIA_LCD_FORCE_SYNC_ACTIVE_HIGH=y
|
||||||
@@ -25,7 +24,7 @@ CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-ol
|
@@ -21,7 +20,7 @@ CONFIG_CMD_USB_MASS_STORAGE=y
|
||||||
CONFIG_SYS_RELOC_GD_ENV_ADDR=y
|
CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-olinuxino"
|
||||||
CONFIG_DFU_RAM=y
|
CONFIG_DFU_RAM=y
|
||||||
CONFIG_FASTBOOT_CMD_OEM_FORMAT=y
|
CONFIG_FASTBOOT_CMD_OEM_FORMAT=y
|
||||||
-CONFIG_AXP_ALDO3_VOLT=3300
|
-CONFIG_AXP_ALDO3_VOLT=3300
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From 7fa26c287b225c5e42be6d1a81d45592ec45bd9c Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
|
|
||||||
Date: Wed, 18 Mar 2020 12:59:01 +0100
|
|
||||||
Subject: [PATCH] configs: a64-olinuxino-emmc: add eMMC boot part config
|
|
||||||
commands
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
mmc bootbus and partconf commands are needed in order to be able to
|
|
||||||
configure booting from separate boot0/boot1 eMMC partitions.
|
|
||||||
|
|
||||||
Signed-off-by: Petr Štetiar <ynezz@true.cz>
|
|
||||||
---
|
|
||||||
configs/a64-olinuxino-emmc_defconfig | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/configs/a64-olinuxino-emmc_defconfig b/configs/a64-olinuxino-emmc_defconfig
|
|
||||||
index 8443a6dae9e3..9a96a964b1dc 100644
|
|
||||||
--- a/configs/a64-olinuxino-emmc_defconfig
|
|
||||||
+++ b/configs/a64-olinuxino-emmc_defconfig
|
|
||||||
@@ -12,6 +12,7 @@ CONFIG_USE_PREBOOT=y
|
|
||||||
CONFIG_DEFAULT_DEVICE_TREE="sun50i-a64-olinuxino-emmc"
|
|
||||||
CONFIG_SYS_RELOC_GD_ENV_ADDR=y
|
|
||||||
CONFIG_SUN8I_EMAC=y
|
|
||||||
+CONFIG_SUPPORT_EMMC_BOOT=y
|
|
||||||
CONFIG_USB_EHCI_HCD=y
|
|
||||||
CONFIG_USB_OHCI_HCD=y
|
|
||||||
CONFIG_SYS_USB_EVENT_POLL_VIA_INT_QUEUE=y
|
|
Loading…
x
Reference in New Issue
Block a user